Exim error (...local_delivery...never_users list)

Here you can find tutorials and notes for server-side maintenance/configuration

Exim error (...local_delivery...never_users list)

Postby lik » Wed Dec 10, 2008 3:58 am

If you get "User 0 set for local_delivery transport is on the never_users list" error on exim_paniclog, you can try to fix it.
The issue appears to be with some of the libraries the following commands should fix it:
Code: Select all
ln -s libdb2.so.3 libdb.so.3
/scripts/eximup --force
/etc/rc.d/init.d/exim restart
lik
Founder
Founder
 
Posts: 497
Joined: Wed Dec 15, 2010 3:21 am

Exim error (webmail)

Postby lik » Sun Dec 28, 2008 11:24 pm

2008-12-28 22:53:33 H=localhost (***.***.***.***) [127.0.0.1] F=<test@domain.com> rejected RCPT <user@anotherdomain.com>: "Your IP: 127.0.0.1 : Your domain domain.com is not allowed in header From"


1. If you use webmail and you get the error mentioned above then your domain is not pointed to our server in local DNS and "Always accept mails locally" option is not set. This applies mainly to Email only hosting clients and those who use Google Apps and this can be fixed through Cpanel:

Login to your cpanel > in Mail section click on MX editor > set "Always accept mails locally" to Yes.

2. If you use php script then most probably you are trying to send message from a domain which is not hosted on our server. E.g. you have feedback form on your site where php script tries to send message as from user's email (someone@google.com, someone@aol.com).

In this case the error can be fixed by using your hosted domain in "from" field and by setting safe_mode to "Off" . Also we recommend you to add 'reply to' header to the message, which will allow you reply to your users.
lik
Founder
Founder
 
Posts: 497
Joined: Wed Dec 15, 2010 3:21 am


Return to Server Side Actions

 


  • Related topics
    Replies
    Views
    Last post